-
ID:yV885n さんの質問

今現在、IEはどのバージョンまで標準で対応されてますか?
どの程度対応されているかも教えていただけますでしょうか?


IE7・・・読めればいい程度、アニメーションなし
IE8・・・レイアウト崩れない程度、透過pngアニメーション時の黒縁非対応、background-size対応

みんなの回答 5 件

ID:Q38Vtr さんの回答

IE9未満は基本未対応(ずれたり動かなくても知らないよ)。
それ以前に対応の場合はそれぞれ別途請求してる。

ID:yV885n

XPもサポートおわったし、そろそろ別途請求してもいい時期かもしれませんね。

ID:QujM4I さんの回答

一般の予想
IE8以上完全対応
IE7以下有料対応

本音
IEそのものに対応したくない。
これまでが裏切りすぎ。いろんなツールバーを自動インストールできるという、はた迷惑なブラウザはユーザーにとっても利益にならない。まさにMSの都合主義のためだけに存在するブラウザ。

ID:WVjeYp

これだね。
自治体、病院、金融系はまだIE7以下対応求められることが多い。
結局vistaがサポートされてる以上、あと数年間はIE8,IE7を完全に切り捨てできないだろうからな。

ID:yV885n

同じくIEを見捨てたいくらいです…せめてW3Cくらい準拠してほしい…

ID:QujM4I

Macで開発していると特そう思うんだけど、Chrome/Firefox/Safari/Operaで確認すれば、最終的にWindowsとの差はフォント差ぐらいなもんだけど、IEに関してはバージョンがどれだけあがっても、IE個別対応みたいな感じがとても嫌。まぁ、これは制作の都合。

ID:HDBY1a さんの回答

私は国内大手メーカーと仕事してますが、IE8以上は必須です。

ID:HDBY1a

そうそう、LPやパララックス、プロモーションページなんかは、IEの優先価値は低くなるかな。静止画でオッケーとかね。要は臨機応変、交渉次第、ケースバイケース。

ID:yV885n

パララックスとかになると対応は難しそうですね。
8が無くなるだけで結構救われるのですが…

ID:agBZjv さんの回答

8で分かれるだろうね。7以下はもう対応してない所が多いだろう。8はしたりしなかったり。9以上はモダンブラウザと変わりないのでラクだよね。

ID:GRGgFU

9は昔の7的な面倒臭さがある

ID:yV885n

9にtransitionが無いのが唯一残念なところですね。あと何年かしたら邪魔者扱いになりそう。

ID:9xmldt さんの回答

XP終了のお知らせが来てからやっと7以下をきったところ。
今は動作確認さえしない。

8はまだ対応してくれと言われることが多いのでやむなくするけど、
とりあえずレイアウト崩れなくて内容がちゃんとわかる程度しか考慮してない。
アニメーションとか動かなくても放置。

ID:yV885n

サポート終了した直後、IEに致命的なバグ出たから8まで終了かと期待したのですが、マイクロソフトが特別にパッチだしたのが残念です。いらん事しやがって…
やはりレイアウトは見れる程度ですね。

最終更新日:2014-07-24 (6,125 views)

関連するトピックス

ページ上部に戻る