W3QはBiztterに生まれ変わりました!
Web制作に関するお悩みはBiztterへどうぞ!

Biztterで質問する

ID:8J7its さんの質問

みなさんはgulp.jsでどんなパッケージ使っていますか?
私は、
.

  • browser-sync
  • gulp
  • gulp-changed
  • gulp-convert-newline
  • gulp-imagemin
  • gulp-pleeease
  • gulp-plumber
  • gulp-sass
  • gulp-sourcemaps
  • gulp-uglify
    .
    を使ってます。
    .
    皆さんのご自慢のパッケージリストを教えてください!

みんなの回答 4 件

ID:xGPgbB さんの回答

普段は警察官の仕事をしているので
あくまで趣味でやっているだけですが・・・


  • html
    css
    java scrption
    php

  • 私のパッケージリストはこんな感じです

ID:8J7its

んんんん?!

ID:6MAMPn さんの回答

最近は動的なものが多いので使うことも少ないが、静的な HTML を作る時は EJS 入れてるかな。

ID:8J7its

EJSなどのテンプレートエンジンもあると確かに良いですね。
それにしても最近は新しいテンプレートエンジンが出てこないですね。

ID:6MAMPn

出力が <% %> でしかできないのがネック。if 文で条件分岐とかするとエディタのタグの色分けが狂って困る。あと cssnext 入れてるかな念のため。

ID:8J7its

EJSは社員で統一して使おうとするにはわかりにくいって結論になって入れれてないんだよなー。(コンパイル失敗時にもゴミが吐き出されるとかだったか、覚えてないけど。)
.
いつまでもSass使ってないでcssnextとか使ったほうがいいんかなあ。

ID:6MAMPn

sass 使ってるよ。通した後に cssnext かましてる。

ID:8J7its

なるほど

ID:3FkFvC さんの回答

jade,compass,webserverをいれてるよ。

ID:8J7its

compassのベンダープリフィクス付与機能って、Can I useに基づいてないから息してないと思ってたんだけど、今はもう大丈夫なん?

ID:3FkFvC

え、そうなの? まったく不便に感じたことはなかったけど。。

ID:z.E8vi さんの回答

node.jsのバージョン違うと動かなくなったり、エラーログうざいから使うの辞めた

ID:8J7its

確かにそういうことも起こりますね。
.
個々のパッケージのバージョンが上がって記述方法が変わってエラーになったりとかもありますね。
.
node.jsのバージョンやpackage.jsonを統一していれば特に問題は起こりにくいですが、多少でも厄介だと業務に支障が出ますよね。

ID:6MAMPn

nodist と npm で解決。

最終更新日:2017-02-14 (490 views)

関連するトピックス

ページ上部に戻る