-
ID:ChbhUl さんの質問

Googlemapをiframeでサイトに埋め込み、IE11の開発者ツールを見ると、コンソールで
「"HTTPS セキュリティが https://www.google.com/maps.... によって危害を受けています"」
とエラーを吐きます。同じように埋め込んでいるサイトを見るとどれも同じエラーを吐いています。
調べみたのですがよく分からず・・・
原因と解決方法を教えてください。

みんなの回答 1 件

ID:0draUx さんの回答

httpのサイトにhttpsを埋め込むと出るっぽいね。


  • 本来は主に逆の場合を意図したエラーメッセージなんだろうけど、httpとhttpsが混在してるといっしょくたに出るのであろう。
    親ページもhttpsにすればエラー出ないはず。

  • どこでも出るので、もう気にしないか、
    納品ガイドライン上とかで出てはまずいとかなら、埋め込みではなくJavaScriptでマップ表示する方法にすればエラー出ないと思います。

ID:ChbhUl

どこも出てますよねぇ。
https or JavaScriptで確かに解決しそうですがそこまで対応する必要はないので現状ままで気にしないとしておこうと思います。
回答いただきありがとうございました。

最終更新日:2014-12-12 (12,068 views)

関連するトピックス

ページ上部に戻る