-
ID:GG4Uoh さんの質問

wordpressのpタグが自動的に挿入されないようにする対策で下記のようにしてるけど効果がありません。バージョンはwordpress3.7.1です。

functions.phpに<?php remove_filter(’the_content’, ’wpautop’); ?>を追加しても効果はありません。

同じくwordpress3.7.1でpタグ消している方はいますか?それとも消せなくなったのかな?

<?php
/*
Template Name: hoge
*/

the_post();
remove_filter(’the_content’,’wpautop’);
the_content();
?>

みんなの回答 2 件

ID:TQHikH さんの回答

みなさんありがとうございます。自己解決いたしました。
これは入れとけ!的な定番プラグインが原因だったみたいです。
一つ一つプラグインを無効化して試してみたらpタグが消えました。

ID:qHxfsB

良かったですね(・∀・)
ただ、障害になってたのがどのプラグインか書いてもらえると
他の方のためにもなるかもです(定番ということですし)。

ID:lrTMHq さんの回答

関係ないだろうけど参考に。これ入れとくといいよ。WPのオートフォーマットはクセがヘンだけど、これだと割とノーマル。

Modify paragraph formatting plugin “PS Disable Auto Formatting" ...

http://www.web-strategy.jp/wp_plugin/ps_disable_auto_formatting/
最終更新日:2013-11-05 (3,256 views)

関連するトピックス

ページ上部に戻る